You can move around with your keyboard
plus
minus
left
right
Drop pin on the map to start a new report
space
Press space again to adjust the location
space
Back to all reports

Cycle lane lights not working

Reported via desktop in the Suggested improvements category anonymously at 16:39, Friday 15 April 2022

Sent to Oxfordshire County Council less than a minute later

Waited for ages for the red light to change on the cycle lane. Ended up having to jump the lights because it was not changing.

Council ref: 3460974

RSS feed of updates to this problem Receive email when updates are left on this problem.

Updates

  • Thank you for your suggestion, it will be added to a list which are assessed and prioritised by our Safety Team. We will now close this report, but if your suggestion gets selected for action we will let you know.

    Posted by Oxfordshire County Council at 16:39, Friday 15 April 2022

  • I think the sensor is not working for the cycle lane, so it does not sense we are there and does not change to green. It works/changes to green if there is a bus or taxi in that lane. Very annoying

    Posted anonymously at 19:42, Friday 15 April 2022

Provide an update

Please note that updates are not sent to the council. Your information will only be used in accordance with our privacy policy

Next: Tell us about you

or No personal details will be stored, and you will not receive updates about this report.

Your update

Tell us about you

Do you have a FixMyStreet password?