Back to all reports

Pedestrian crossing not working properly

Reported in the Traffic Lights (permanent only) category anonymously at 20:29, Monday 8 July 2019

Sent to Oxfordshire County Council 1 minute later

The crossing on cutteslowe roundabout (wolvercote roundabout side, second half on the Oxford side, crossing the A40 westbound) resets itself without showing the green man after you press the button. I use it c. 4 times a week and it does it most times

RSS feed of updates to this problem Receive email when updates are left on this problem.

Updates

  • You should now find this issue has been resolved.

    State changed to: Fixed

    Posted by Oxfordshire County Council at 14:23, Tuesday 9 July 2019

  • Still open, via questionnaire, 21:12, Monday 5 August 2019

  • The issue is still happening

    State changed to: Open

    Posted anonymously at 21:14, Monday 5 August 2019

  • Damage was caused to my car suspension on the evening of August 4th when coming off a roundabout on the A40 driving west into Sunderland Avenue. My wheel hit the edge of the missing kerbstone (see picture) and caused a loud bang. I now have tracking and camber problems on three of my wheels.

    Posted anonymously at 11:36, Thursday 15 August 2019

  • The operation of the pedestrian crossings have been checked and found to be working. We will continue to monitor the site.

    State changed to: Fixed

    Posted anonymously at 12:41, Wednesday 28 August 2019

Provide an update

Please note that updates are not sent to the council. Your information will only be used in accordance with our privacy policy

Next: Tell us about you

Your update

Tell us about you

Do you have a FixMyStreet password?